Archived

This topic is now archived and is closed to further replies.

MysticalOS

[Fixed] DBM StartCombat Debug

3 posts in this topic

If you are using an alpha version you may notice dbm printing out debug information when bosses are engaged. This is being done because of a new issue that's cropped up in LFR

it seems lately when in LFR, boss pulls are being spoofed or rather, dbm is being tricked that a boss is being pulled that isn't actually being pulled. We believe this is spoofing (someone sending bad pull syncs either by accident via some weird 3rd party mods, or on purpose for purpose of trolling dbm users).

When this happens, you see a "boss name engaged" in a place that's pretty much impossible. The debug should print where this bad information is coming from to help troubleshoot exactly the cause and ensure it's not a bug in our part as well as call out who is sending bad information to identify if it's on purpose or by accident.

We believe it's a spoof because the issue has never had any reports in following raids:

normal/heroic runs.

premade LFR groups

Solo raids.

The issue has come up repeatedly in pug LFR groups where you don't know others in run.

What we're hoping, is when users see these bad pulls happen, they can report or screen cap the debug prints dbm produces and post here to help diagnose the cause. The prints should contain source event of combat start, as well as "true" if an actual encounter is in progress. hopefully it says "true" on all genuine pulls. if it does, i'll be adding code to ignore syncs that aren't genuine.

Share this post


Link to post
Share on other sites

Note that we will probably simply reject sync pulls in LFR if you are not in a boss fight (IsEncounterInProgress()).

Share this post


Link to post
Share on other sites

We believe it's a spoof because the issue has never had any reports in following raids:

normal/heroic runs.

The issue has come up repeatedly in pug LFR groups where you don't know others in run.

I just registered here to see if there is a known issue about these debug messages I see sometimes at the beginning of an encounter. So I found this thread (hope this is the right place to post...)

Yesterday I got this message "DBM combat debug: Combat started by UNIT_HEALTH. Encounter in progress: false" several times in a row while fighting Tsulong in a normal 10man guild raid.

I also got his message some days ago while soloing Attumen in Karazhan (I still believe he hides a mount somewhere ^^).

So it doesn't seem to be restricted to LFR groups only.

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.