Archived

This topic is now archived and is closed to further replies.

wanededuoduo

DBM RAID TOOLS

13 posts in this topic

Dear all

 

I want to use the bidbot in the Raidleadtools. But the current version cant be active in wow 5.4. Can you help me look inside it?

 

Thanks.

Share this post


Link to post
Share on other sites

The bidbot in DBM RAIDtools Revision 113 on curse  just can not be enabled in game.The check before the option disappear automatically. I will snap the picture when I get home. 

I will test the revision 117 on SVN to see whether it works.

I dont see any lua error in game , perhaps my addon block it.

 

Thanks for reply,

 

When i get the result , i will inform here asap.

Share this post


Link to post
Share on other sites

If you mean it saying (out of date) just check "load out of date) it should work. I don't think we raised the TOC on that one since we never actually tested mod for 5.4 but it shouldn't be broken.

Share this post


Link to post
Share on other sites

Sorry for the bad expression. But I dont mean out of date. The addon is loaded but the bidbot function can not be enabled.

Perhaps something not be updated to be run under 5.4.

Share this post


Link to post
Share on other sites

Sorry, the R117 on SVN can not use. 

But I ask someone to modify the current version and now it can be enabled.

 

Thanks.

Share this post


Link to post
Share on other sites

For anyone who is interested in solving the above problem...

The plugins are still working fine...you just have to edit the bidbot.lua and the standbybot.lua:

 

In both lua files search for DBM:IsInRaid() and remove the DBM:

if settings.enabled and DBM:IsInRaid() ---> if settings.enabled and IsInRaid()

 

After removing all DBM: bits, it'll work again! :)

 

Enjoy!

Share this post


Link to post
Share on other sites

Tested the StandbyBot today...

 

Regardless if a player is IN the raid or if he's not...if the person whispers !sb to the raidlead, he get's the message "you have to leave the raid..."

elseif settings.enabled and event == "CHAT_MSG_WHISPER" and IsInRaid() then
			local msg, author = select(1, ...)
			if msg == "!sb" then
				if DBM:GetRaidUnitId(author) == "none" then
					AddStandbyMember( author )
				else
					SendChatMessage("<DBM> "..L.InRaidGroup, "WHISPER", nil, author)
				end
			elseif msg == "!sb off" then
				RemoveStandbyMember( author )
			end

It seems that 

...if DBM:GetRaidUnitId(author) == "none" then...

yields something else than "none" thus the else branch is called...

 

Could someone help me fix that? Would be nice to use those Tools again!

 

If it would be better suited in the "help" section i'll make a new post there if needed.

Share this post


Link to post
Share on other sites

SBBot seems to work now :) people not in the raid get flagged for beeing standby if they whisper !sb...

I'll test it in the raid tomorrow and give you further feedback...

 

Regarding the BidBot...wasn't there a "check" if the whispered bid was greater/equal to the minbid...and if it is below the set minbid that those bids would not be accepted?...could be wrong...but currently the bot also accepts bids below the set minimum...

Could not test the "can somebody outside the raid start a bid" feature...will do that tomorrow aswell...

 

But thx for looking into it :) much appreciated!

Share this post


Link to post
Share on other sites

  • Recently Browsing   0 members

    No registered users viewing this page.