Jump to content


Photo

Macro help/advice


  • Please log in to reply
82 replies to this topic

#1 Goggles

Goggles

    King Hippo

  • Members
  • 571 posts

Posted 24 May 2007 - 09:28 AM

I've finally got round to playing with focus options and have been trying to create a macro for polymorph (and for CS/Spellsteal).

Currently what I've got is the following:

/clearfocus [button:2]
/focus [target=focus,noexists]
/cast [target=focus] Polymorph: Turtle
/stopmacro [nogroup:raid]
/script SendChatMessage(UnitName("focus").." polymorphed (50s)","RAID")

This clears focus if I use right mouse button, focuses on current target if I don't have a focus already, polymorphs focus and sends a message to raid if I'm in one.

While at a basic level this does what I want I'd like to improve it in a few ways.

1. I'd like to be able to hotkey this. Do I need to create 2 macros, 1 with /clearfocus in and 1 without and use different hotkeys for each or do modifiers work in some way with hotkeys?

2. Is it possible to do something like:
/stopmacro [nogroup:raid, target=focus, noexists, noharm]
This would stop macro if not in raid group or if focus doesn't exist or not an enemy. I imagine this won't work but is there a way to streamline this so it doesn't take up 3 lines?

3. The reason I use /script SendChatMessage(...) is to put the focus name in the message. It would be nice to be able to use "/r %f polymorphed (50s)" or something to that effect. WowWiki seemed to suggest this wasn't possible but there seemed to be some inconsistency between it's macros.

Is there a decent reference/forum for macros other than WowWiki? Currently it's the only place I know of with this kind of information but I'm never sure of it's accuracy or whether it is uptodate with all the latest commands.
Not actually a member of Refusion on Burning Blade.

#2 Cel

Cel

    Great Tiger

  • Members
  • 759 posts

Posted 24 May 2007 - 01:25 PM

New in 2.1 you can use %f to display your focus' name.
"There is much pleasure to be gained from useless knowledge." - Bertrand Russell

Alpha is recruiting... go go.

#3 Chicken

Chicken

     

  • Moderators
  • 3,639 posts

Posted 24 May 2007 - 01:34 PM

Your suggested /stopmacro should work, though you might have to remove the spaces.

#4 Sarutobi

Sarutobi

    Bald Bull

  • Allied Members
  • 1,394 posts

Posted 24 May 2007 - 02:14 PM

I'm not 100% about the syntax in the /stopmacro so I'll leave that part alone.

As far as hotkeying the focus clear it's fairly simple. Instead of having the [button:2] you just need to change that to a modifier key (ctrl, alt, shift).

/clearfocus [modifier:alt]

Now instead of a right mouse click, whenever you hold down alt while pressing your hotkey it will clear your focus target.

#5 Goggles

Goggles

    King Hippo

  • Members
  • 571 posts

Posted 24 May 2007 - 02:48 PM

Thanks for the info guys, I'll test this all tonight hopefully.
Not actually a member of Refusion on Burning Blade.

#6 mohadeeb

mohadeeb

    Glass Joe

  • Members
  • 1 posts

Posted 22 July 2010 - 01:40 AM

ok i would like any help i may get on this macro.

i need a macro that can use my Misdirection on the focus target .

#showtooltip
/cast [target=focus,help] Misdirection;[help]Misdirection; [target=pet, exists] Misdirection

now how do i make a macro to change Focus from the 2 main tanks "jim" to "joe" and then from "joe" to "jim" in a raid .

any ideas? thank you

#7 Smidjet

Smidjet

    Glass Joe

  • Members
  • 1 posts

Posted 01 August 2010 - 04:39 PM

i dont know much about macros, but i would put a mouseover option in there to over ride the focus. that way you focus one tank and mouseover the over. if now focus or mouseover it would cast on pet. i found a macro that does that on Wowiki. but not on my gaming computer to copy and past it.

ok i would like any help i may get on this macro.

i need a macro that can use my Misdirection on the focus target .

#showtooltip
/cast [target=focus,help] Misdirection;[help]Misdirection; [target=pet, exists] Misdirection

now how do i make a macro to change Focus from the 2 main tanks "jim" to "joe" and then from "joe" to "jim" in a raid .

any ideas? thank you



I found a macro similar to what you have on wowiki. As for what you are looking to do, i would just put in mouseover comand that would overrule the focus so as to MD the non focus tank. The macro i found on wowiki did this.

/cast [@mouseover,help] Misdirection; [@focus,help] Misdirection; [help] Misdirection; [@pet,exists] Misdirection

that is the macro i have.

#8 Jswerve

Jswerve

    Glass Joe

  • Members
  • 1 posts

Posted 18 August 2010 - 09:22 PM

Hello all. I am using this arcane macro that i found and everything works except when missile barrage procs i am supposed to be able to just hold down the shift key and use the same button but its not working.

#show Arcane Blast
/cast Presence of Mind
/cast Icy Veins
/cast Arcane Power
/use 13
/use 14
/cast Arcane Blast
/cast [mod:shift] Arcane Missiles
/run UIErrorsFrame:Clear()

Can someone please identify the problem? Ty in advance.

#9 zimira

zimira

    Von Kaiser

  • Members
  • 53 posts

Posted 18 August 2010 - 10:00 PM

You probably need the cast lines to be as follows:

/cast [nomod] Arcane Blast
/cast [mod:shift] Arcane Missiles

Otherwise it will cast AB even if you hold shift.

#10 Parnage

Parnage

    Glass Joe

  • Members
  • 3 posts

Posted 19 August 2010 - 03:57 AM

I am sorry I have no idea where to put this topic/question.

I have a question that I was not able to find doing a search. It is related to my prot pally but others as well. Two days ago I upgraded to windows 7 since it was a lighter app than Vista I had. Everything went smoothly but now my macros are not saved after I log out and log back in. Also my addons are not showing up when I log in. I do not even have the addon options button in the lower left of the character selection screen. They are in the addons folder in WoW but are not showing up after login. Any ideas as to what is causing the hang-up? I am trying to avoid having to remove and reinstall WoW.

#11 Slash

Slash

    Piston Honda

  • Members
  • 105 posts

Posted 19 August 2010 - 09:54 AM

I am sorry I have no idea where to put this topic/question.

I have a question that I was not able to find doing a search. It is related to my prot pally but others as well. Two days ago I upgraded to windows 7 since it was a lighter app than Vista I had. Everything went smoothly but now my macros are not saved after I log out and log back in. Also my addons are not showing up when I log in. I do not even have the addon options button in the lower left of the character selection screen. They are in the addons folder in WoW but are not showing up after login. Any ideas as to what is causing the hang-up? I am trying to avoid having to remove and reinstall WoW.

Where do you have WoW installed? If it is in 'C:\Program Files\...' then WoW can not write to its own directory without admin rights, which would stop it creating/modifying the files containing the macro's.

Either try moving the WoW install to 'C:\Users\[username]\Games' and running it from there or run WoW as administrator (Right-Click on the shortcut and click 'Run as Administrator'.

#12 dessembrae

dessembrae

    Glass Joe

  • Members
  • 8 posts

Posted 19 August 2010 - 10:22 AM

I am sorry I have no idea where to put this topic/question.

I have a question that I was not able to find doing a search. It is related to my prot pally but others as well. Two days ago I upgraded to windows 7 since it was a lighter app than Vista I had. Everything went smoothly but now my macros are not saved after I log out and log back in. Also my addons are not showing up when I log in. I do not even have the addon options button in the lower left of the character selection screen. They are in the addons folder in WoW but are not showing up after login. Any ideas as to what is causing the hang-up? I am trying to avoid having to remove and reinstall WoW.



When you say you "upgraded to Windows 7" did you actually upgrade your Vista install or do you do a fresh, clean install?
If it was an upgrade then WoW should be totally unaffected as Vista's permission handling is pretty much identical to Windows 7.

Did you reinstall WoW from fresh is another viable question at this point. Your addons live in your WoW folder in the path
"<wow install folder>\Interface\Addons". Your Macros are saved to "<wow install folder>"\WTF\<Account name>\<realm name>\<character name>\macro-cache.txt (I think it is a text file).

If you did a totally clean windows install (involving a format) and WoW reinstall, you have NO addons folder for WoW to find. If you did an upgrade but reinstalled WoW, have a look to see if you reinstalled to same location you used to run it from. If it is in a new folder, just find your old install and update the shortcut you use to point at the old location. Thankfully WoW is not totally depended on registry entries so it should just fire up quite happily.

#13 Parnage

Parnage

    Glass Joe

  • Members
  • 3 posts

Posted 19 August 2010 - 06:44 PM

No is was just an upgrade, no formatting. I will try the run as admin to see if I have any results.

I did try running as admin. I logged in, copied a quick macro then logged out and still no luck. I does not seem to remember any setting that I have within the game. Same with my addons they do not show up either. Guess I am looking at a reinstall :-(

#14 Bouhb

Bouhb

    Glass Joe

  • Members
  • 5 posts

Posted 19 August 2010 - 07:33 PM

Sadly I have suffered the same and it was a visu that was causing it, which was of course a bad thing.
Have you tried a full sweep with AV-software adaware, spybot and such?

#15 f1reburn

f1reburn

    Piston Honda

  • Members
  • 126 posts

Posted 21 August 2010 - 04:11 PM

I'm looking for a macro that focuses my mouseover target, and if it finds none it focuses the regular target.

This type of macro is usually easy to make, for example /cast [target=mouseover,harm,exists,nodead] Ice Lance; Ice lance

When I try to apply this to focus, it doesn't work. I've tried /focus [target=mouseover] [] but that doesn't seem to work either.

#16 kemÃ

kemÃ

    Glass Joe

  • Members
  • 13 posts

Posted 21 August 2010 - 05:36 PM

I'm looking for a macro that focuses my mouseover target, and if it finds none it focuses the regular target.

This type of macro is usually easy to make, for example /cast [target=mouseover,harm,exists,nodead] Ice Lance; Ice lance

When I try to apply this to focus, it doesn't work. I've tried /focus [target=mouseover] [] but that doesn't seem to work either.


I don't believe it's possible to set a focus target without actually targetting the unit that you want to focus first. The only macro command available to set one is /focus, which can't be used with a mouseover command, it's not possible to do with a /script command either as FocusUnit() and ClearFocus() are protected functions.

#17 Ravelvan

Ravelvan

    Von Kaiser

  • Members
  • 41 posts

Posted 21 August 2010 - 07:16 PM

I'm looking for a macro that focuses my mouseover target, and if it finds none it focuses the regular target.

This type of macro is usually easy to make, for example /cast [target=mouseover,harm,exists,nodead] Ice Lance; Ice lance

When I try to apply this to focus, it doesn't work. I've tried /focus [target=mouseover] [] but that doesn't seem to work either.


Hmm, it seems to work just fine when I try it:
/focus [target=mouseover,exists][]


#18 f1reburn

f1reburn

    Piston Honda

  • Members
  • 126 posts

Posted 22 August 2010 - 07:45 AM

Much appreciated, it appears the 'exists' did the trick. :)

#19 natas0733

natas0733

    Glass Joe

  • Members
  • 1 posts

Posted 14 October 2010 - 08:19 AM

i would like to macro maul with mangle. before 4.0.1 i used this macro

#showtooltip
/cast mangle (bear)
/cast !maul

it no longer works for some reason. Anybody know why?

#20 Venatia

Venatia

    Glass Joe

  • Members
  • 3 posts

Posted 14 October 2010 - 10:23 AM

i would like to macro maul with mangle. before 4.0.1 i used this macro

#showtooltip
/cast mangle (bear)
/cast !maul

it no longer works for some reason. Anybody know why?


By the looks of it, the spell "Mangle (Bear)" doesn't exist anymore, it seems to be just "Mangle" now.
(So remove the " (bear)" part from the macro and it should work.)

On a different note: anyone knows if it's possible to macro the flyout-stuff?
Ideally I'd get something in the lines of

/cast [mod:shift] Portal; Teleport

But this doesn't work, and neither does /use
(All very logical since you don't actually cast a spell or use an item, but then what to do?)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users