Jump to content


Photo

NOTICE: 5.3 and DBM sounds in combat


  • Please log in to reply
10 replies to this topic

#1 MysticalOS

MysticalOS

    French Hacker

  • ♦ Administrators
  • 765 posts
  • LocationGeorgia

Posted 22 May 2013 - 01:30 AM

Something is seriously wrong with PlaySoundFile()

seems mods get very low sound channel priority now so our sounds get muted or clipped

DBM Problems Since Patch 5.3 - Forums - World of Warcraft
No sound notifications from any addons - Forums - World of Warcraft
Certain sounds cutting out - Forums - World of Warcraft

when sounds do play, they get truncated by game sounds and heavily clipped.

EDIT
A patch was released to fix clipping issues

However...

Many reports that addon sounds are being forcibly reduced in volume so addon sounds are much softer than they should be, so still not 5.2 behavior by any means. hard to hear over regular in game sounds, even when using master audio channel. so now instead of being unable to hear, they are just hard to hear unless you still turn game sound off and crank speakers up.

#2 MysticalOS

MysticalOS

    French Hacker

  • ♦ Administrators
  • 765 posts
  • LocationGeorgia

Posted 22 May 2013 - 01:46 AM

Just to add, we have discovered a work around.

further analysis. it seems the problem may in fact be a priority queue for sound channel priority. It seems addons were pushed to least important, thus causing combat sounds to clip mods almost entirely when in large enough fight.

25 man raiding, world bosses especially, LFR. if your game sound effects are on and you have 352563 spells going off at once, the new clipping is basically stopping all mod sounds just so it can fill all sound channels with combat sounds.

As it stands now, it's going to net result in addon sounds pretty much never playing in large raids unless you turn your sound effects off. that seems to be the work around, play with no game sound so addons can get sound playback returned.

#3 MysticalOS

MysticalOS

    French Hacker

  • ♦ Administrators
  • 765 posts
  • LocationGeorgia

Posted 22 May 2013 - 02:44 AM

Also, for this solution to work. DBM MUSt be set to use "master" audio channel.

Posted Image

Posted Image

^Should look something like this. Sound on sound effects off, dbm master audio, yes

#4 MysticalOS

MysticalOS

    French Hacker

  • ♦ Administrators
  • 765 posts
  • LocationGeorgia

Posted 22 May 2013 - 06:16 AM

People are still reporting mixed results. i'd be curious if upping sound channels helps any, if turning off sound alone does not. For example, i got my sounds working fine but I use 32 channels, not the default 24. Or even try 64. It's apparent messing with sound settings and reducing the amount of blizzard sound effects goes a long way. (turning off sound effects, music, ambiant, etc)

#5 MysticalOS

MysticalOS

    French Hacker

  • ♦ Administrators
  • 765 posts
  • LocationGeorgia

Posted 22 May 2013 - 03:47 PM

Seems even 10 mans are pretty much a no go for combat sounds and addon sounds working together.
you're pretty much forced into soundless raiding to have working addon sounds

#6 oscarucb

oscarucb

    Glass Joe

  • Members
  • 2 posts

Posted 22 May 2013 - 04:02 PM

Obviously, Blizzard really needs to fix this horrible bug.

Although knowing them, as a bug that "only affects third-party addons", it could be awhile. Let's be honest, based on past experience it may take them months to even officially acknowledge the problem.

In the meantime, the options of no game sounds or no DBM sounds are both pretty awful for raiders who are accustomed to relying upon cues from both. Is there a better temporary workaround?

Here's a possible (simplified) idea:

local function DBM_PlaySoundFile(file)
  local user_setting = GetCVar("Sound_EnableSFX") 
  SetCVar("Sound_EnableSFX","0")
  -- delay?
  PlaySoundFile(file, "Master")
  SetCVar("Sound_EnableSFX",user_setting)
end

NOTES: Based on simple tests, I suspect Sound_EnableSFX does not actually clear the sound queues immediately, just mutes sounds in-progress and drops new SFX enqueues - so in order to be effective this hack might actually need a more sophisticated approach that inserts a short delay (0.5sec?) where indicated. A brief pause should be statistically sufficient for some or the shorter queued sounds to complete and free up a slot, without making the addon sound too late to be useful. This would probably also cause a noticeable "jitter" in the game sounds, but that seems preferable to the previous alternatives of zero DBM sounds or zero game sounds.

Of course, this means you need an asynchronous version of the code that schedules the second half to play later, and also some additional logic to "do the right thing" when DBM tries to play two sounds in rapid succession. If this curse from the old gods continues long enough, it might even be worth a library to ensure independent addons don't step on each other while doing this.

#7 Arizair

Arizair

    Glass Joe

  • Members
  • 1 posts

Posted 22 May 2013 - 09:36 PM

People are still reporting mixed results. i'd be curious if upping sound channels helps any, if turning off sound alone does not. For example, i got my sounds working fine but I use 32 channels, not the default 24. Or even try 64. It's apparent messing with sound settings and reducing the amount of blizzard sound effects goes a long way. (turning off sound effects, music, ambiant, etc)



Well, it's posted on those links that set at 64, it still has little effect without disabling all sound effects.

Personally, I edited config.wtf to use 96 channels and then made the file read only (displays as "Custom" now in game) and the sounds would still get clipped off half a second in until I disabled all Sound Effects in 25m. Works fine for scenarios/5mans with everything on.

#8 MysticalOS

MysticalOS

    French Hacker

  • ♦ Administrators
  • 765 posts
  • LocationGeorgia

Posted 23 May 2013 - 06:17 AM

https://twitter.com/...333332457185281

https://twitter.com/...302885777944576

#9 Crunchberry

Crunchberry

    Glass Joe

  • Members
  • 1 posts

Posted 23 May 2013 - 06:54 PM

Personally, I edited config.wtf to use 96 channels and then made the file read only (displays as "Custom" now in game) and the sounds would still get clipped off half a second in until I disabled all Sound Effects in 25m. Works fine for scenarios/5mans with everything on.


I set mine to 128, and it works like a charm. However, I suspect that this may not work for some people as some sound cards/USB headset systems may not be capable of >64 sound channels...or even >32 for that matter. Until Blizzard works out its own kinks, this is an acceptable solution imo.

#10 oscarucb

oscarucb

    Glass Joe

  • Members
  • 2 posts

Posted 23 May 2013 - 07:53 PM

For those uncomfortable with editing config.wtf, the in-game incantation is:

/run SetCVar("Sound_NumChannels",128)

Although as Crunchberry mentions this might not work for some sound cards.

#11 MysticalOS

MysticalOS

    French Hacker

  • ♦ Administrators
  • 765 posts
  • LocationGeorgia

Posted 24 May 2013 - 01:22 AM

A patch was released to fix clipping issues

However...

It seems addon sounds are being forcibly reduced in volume so addon sounds are much softer than they should be, so still not 5.2 behavior by any means. hard to hear over regular in game sounds, even when using master audio channel. so now instead of being unable to hear, they are just hard to hear unless you still turn game sound off and crank speakers up.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users