Jump to content


Photo

DBM RAID TOOLS


  • Please log in to reply
12 replies to this topic

#1 wanededuoduo

wanededuoduo

    Glass Joe

  • Members
  • 4 posts

Posted 28 October 2013 - 04:00 AM

Dear all

 

I want to use the bidbot in the Raidleadtools. But the current version cant be active in wow 5.4. Can you help me look inside it?

 

Thanks.



#2 MysticalOS

MysticalOS

    French Hacker

  • ♦ Administrators
  • 939 posts
  • LocationGeorgia

Posted 28 October 2013 - 05:12 AM

What's it do on 5.4? Does it still error?

#3 wanededuoduo

wanededuoduo

    Glass Joe

  • Members
  • 4 posts

Posted 28 October 2013 - 07:07 AM

The bidbot in DBM RAIDtools Revision 113 on curse  just can not be enabled in game.The check before the option disappear automatically. I will snap the picture when I get home. 

I will test the revision 117 on SVN to see whether it works.

I dont see any lua error in game , perhaps my addon block it.

 

Thanks for reply,

 

When i get the result , i will inform here asap.



#4 MysticalOS

MysticalOS

    French Hacker

  • ♦ Administrators
  • 939 posts
  • LocationGeorgia

Posted 28 October 2013 - 07:09 AM

If you mean it saying (out of date) just check "load out of date) it should work. I don't think we raised the TOC on that one since we never actually tested mod for 5.4 but it shouldn't be broken.

#5 wanededuoduo

wanededuoduo

    Glass Joe

  • Members
  • 4 posts

Posted 28 October 2013 - 08:14 AM

Sorry for the bad expression. But I dont mean out of date. The addon is loaded but the bidbot function can not be enabled.

Perhaps something not be updated to be run under 5.4.



#6 wanededuoduo

wanededuoduo

    Glass Joe

  • Members
  • 4 posts

Posted 28 October 2013 - 03:28 PM

Sorry, the R117 on SVN can not use. 

But I ask someone to modify the current version and now it can be enabled.

 

Thanks.



#7 Catherine91

Catherine91

    Glass Joe

  • Members
  • 1 posts

Posted 12 November 2013 - 11:25 AM

Thanks for info.


Edited by Catherine91, 13 March 2014 - 09:13 AM.


#8 Varon

Varon

    Glass Joe

  • Members
  • 29 posts

Posted 18 November 2013 - 03:01 AM

For anyone who is interested in solving the above problem...

The plugins are still working fine...you just have to edit the bidbot.lua and the standbybot.lua:

 

In both lua files search for DBM:IsInRaid() and remove the DBM:

if settings.enabled and DBM:IsInRaid() ---> if settings.enabled and IsInRaid()

 

After removing all DBM: bits, it'll work again! :)

 

Enjoy!



#9 MysticalOS

MysticalOS

    French Hacker

  • ♦ Administrators
  • 939 posts
  • LocationGeorgia

Posted 18 November 2013 - 03:04 AM

I'm pretty sure I already commited those updates, just not to curse.



#10 Varon

Varon

    Glass Joe

  • Members
  • 29 posts

Posted 18 November 2013 - 03:10 AM

Hm...I only found them on curse, they were not working and after using google I found this thread and thought it might help others to know how to fix it manually ;)

 

It seems that they are not listed here at all: http://forums.elitis...howtopic=131336


Edited by Varon, 18 November 2013 - 03:12 AM.


#11 Varon

Varon

    Glass Joe

  • Members
  • 29 posts

Posted 18 November 2013 - 06:40 PM

Tested the StandbyBot today...

 

Regardless if a player is IN the raid or if he's not...if the person whispers !sb to the raidlead, he get's the message "you have to leave the raid..."

elseif settings.enabled and event == "CHAT_MSG_WHISPER" and IsInRaid() then
			local msg, author = select(1, ...)
			if msg 
"!sb" then if DBM:GetRaidUnitId(author)
"none" then AddStandbyMember( author ) else SendChatMessage("<DBM> "..L.InRaidGroup, "WHISPER", nil, author) end elseif msg == "!sb off" then RemoveStandbyMember( author ) end

It seems that 

...if DBM:GetRaidUnitId(author) == "none" then...

yields something else than "none" thus the else branch is called...

 

Could someone help me fix that? Would be nice to use those Tools again!

 

If it would be better suited in the "help" section i'll make a new post there if needed.


Edited by Varon, 18 November 2013 - 07:02 PM.


#12 MysticalOS

MysticalOS

    French Hacker

  • ♦ Administrators
  • 939 posts
  • LocationGeorgia

Posted 25 November 2013 - 10:19 AM

Tell me if new version from HERE works. r118.

#13 Varon

Varon

    Glass Joe

  • Members
  • 29 posts

Posted 25 November 2013 - 02:53 PM

SBBot seems to work now :) people not in the raid get flagged for beeing standby if they whisper !sb...

I'll test it in the raid tomorrow and give you further feedback...

 

Regarding the BidBot...wasn't there a "check" if the whispered bid was greater/equal to the minbid...and if it is below the set minbid that those bids would not be accepted?...could be wrong...but currently the bot also accepts bids below the set minimum...

Could not test the "can somebody outside the raid start a bid" feature...will do that tomorrow aswell...

 

But thx for looking into it :) much appreciated!






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users