Jump to content


Photo

WoW and FRAPS


  • Please log in to reply
176 replies to this topic

#1 Illundai

Illundai

    Bald Bull

  • Members
  • 1239 posts

Posted 23 February 2008 - 08:29 PM

Apologies if this is deemed too specific or in any case posted in the wrong forum (couldn't think of a better forum than this one to post it in though).

First of all, let me mention that I bought a new computer in the end of November. My computer specs:

Intel Q6600 2.4ghz.
4096 mb ddr2 RAM.
Asus P5E mainboard
2xAsus EN8800GT
and onboard sound (yes, I know..)
4x250GB HDD (~300 gb free space)

Now, correct me if I'm wrong, but that PC should be able to decently FRAPS. Well, that's the problem. It doesn't. I can record at 45 fps out of combat, but as soon as I enter combat the FPS plummet to 5. This strikes me as odd considering I could fraps at 15+ fps with my old rig, which was 3,5 years old or something.

I shrugged it off and didn't think much of it, we all know that WoW is extremely CPU heavy and maybe I was just hoping for too much. Then I tried turning on FRAPS in Call of Duty 4 and lo, behold... 30 fps constant while frapsing at max settings with 1280x1024 as resolution.
I don't get it. Is it addons that are screwing me over? Is it my CPU? It could be my CPU, considering CoD4 is more of a GPU dependant game, I guess.

I run 2 screens if that matters in any way, I turn off Windowed mode when raiding to gain FPS. I run WoW in 1280x1024 with max settings. I turn sound off.

I'm confused. I'm sure I should get higher FPS while frapsing, any hints or suggestions? I decided upon making a thread here as I'm sure competent people that can help me further browse these boards. This is in no way a thread just to answer my question, maybe we can share tips on how to smoothen recording in WoW.

#2 Kytrarewn

Kytrarewn

    In 1st, e-brake activated.

  • Members
  • 4069 posts

Posted 23 February 2008 - 08:36 PM

FRAPS doesn't play nicely with SLI.
Don't let this asshole be a US Senator:

ΜΟΛΩΝ ΛΑΒΕ


Jesus don't want me in a sunbeam
Sunbeams are always made on me
Don't expect me to cry, for all the reasons I'm gonna die
Don't ever ask your kick of me.

#3 Illundai

Illundai

    Bald Bull

  • Members
  • 1239 posts

Posted 23 February 2008 - 08:41 PM

Yah, damnit I knew I forgot something. I heard about that so I tried turning it off, didn't help much. Thanks though :<.

#4 Kytrarewn

Kytrarewn

    In 1st, e-brake activated.

  • Members
  • 4069 posts

Posted 23 February 2008 - 08:55 PM

You also can't FRAPS at a higher resolution than your hard-drives can put it down. If you have some sort of RAID-1 routine going on, you could be bottlenecked at the HD.

EDIT: Have you tried forcing WoW affinity to cores 1,2 and FRAPS to 3,4?
Don't let this asshole be a US Senator:

ΜΟΛΩΝ ΛΑΒΕ


Jesus don't want me in a sunbeam
Sunbeams are always made on me
Don't expect me to cry, for all the reasons I'm gonna die
Don't ever ask your kick of me.

#5 Illundai

Illundai

    Bald Bull

  • Members
  • 1239 posts

Posted 23 February 2008 - 09:01 PM

That's something I hadn't heard yet, unfortunatly the store I bought this in were pretty set on doing the assembly themselves and being as dumb as I am, didn't think about doublechecking everything. Do I check this in the BIOS?

About the CPU settings, this is my first multicore, so I have no idea how to do that either.

I'm not completely helpless when it comes to computers, but it's been a while...

#6 Kytrarewn

Kytrarewn

    In 1st, e-brake activated.

  • Members
  • 4069 posts

Posted 23 February 2008 - 09:09 PM

First thing I would try is hard-disabling the second graphics card in the BIOS, rather than just turning off AFR by the nVidia control panel.

With a weaker CPU (5600+ AMD X2) and 1x 8800GT 512, with a standard 7200RPM hard-drive, I can fraps at 50FPS.
Don't let this asshole be a US Senator:

ΜΟΛΩΝ ΛΑΒΕ


Jesus don't want me in a sunbeam
Sunbeams are always made on me
Don't expect me to cry, for all the reasons I'm gonna die
Don't ever ask your kick of me.

#7 Illundai

Illundai

    Bald Bull

  • Members
  • 1239 posts

Posted 23 February 2008 - 09:31 PM

Tried just now, removed the second GPU from the mainboard and loaded up. Same thing still, dropping to sub 10 fps the moment I enter combat.

#8 Kytrarewn

Kytrarewn

    In 1st, e-brake activated.

  • Members
  • 4069 posts

Posted 23 February 2008 - 09:32 PM

kk, try ctrl-alt-delete into task manager. Go into processes. Set WoW.exe to cores 0,1,2 and FRAPS.exe to core 3. See if that helps anything.
Don't let this asshole be a US Senator:

ΜΟΛΩΝ ΛΑΒΕ


Jesus don't want me in a sunbeam
Sunbeams are always made on me
Don't expect me to cry, for all the reasons I'm gonna die
Don't ever ask your kick of me.

#9 Seed

Seed

    Glass Joe

  • Members
  • 2 posts

Posted 23 February 2008 - 09:50 PM

You said you're running 2 screens? With WoW across both screens? I've never done that for WoW so I'm not sure, but if FRAPS is recording both screens at once then yeah that will definitely hurt your fps. Also, are you recording to the same hard drive that you have WoW installed on? I've heard varying reports of this making a difference in performance.

#10 Illundai

Illundai

    Bald Bull

  • Members
  • 1239 posts

Posted 23 February 2008 - 09:55 PM

Yeah, running 2 screens, but WoW is only on one. I tried the cores thing, helped a little but not much... I am recording to the same HD as WoW is installed on, but would that make such a difference? I always have done this as far as I can remember back :o

[e] Just tried recording to a different HD, made no difference.

#11 Kytrarewn

Kytrarewn

    In 1st, e-brake activated.

  • Members
  • 4069 posts

Posted 23 February 2008 - 10:00 PM

What's your total amount of space? Is it 500GB for all 4 drives or is it a solid 1GB. I'm trying to figure out why, without raid-striping, they would go with 4x250 rather than the much cheaper 500x2 approach, even then.
Don't let this asshole be a US Senator:

ΜΟΛΩΝ ΛΑΒΕ


Jesus don't want me in a sunbeam
Sunbeams are always made on me
Don't expect me to cry, for all the reasons I'm gonna die
Don't ever ask your kick of me.

#12 Illundai

Illundai

    Bald Bull

  • Members
  • 1239 posts

Posted 23 February 2008 - 10:05 PM

It's a remnant of gradually upgrading. I only bought a new 250 GB HD to go along with my other 3 I already had.

They're all 7200 RPM, if that matters t_t. The total amount of HD space is ~300GB spread out along over the 4 drives.

#13 kniff

kniff

    Glass Joe

  • Members
  • 16 posts

Posted 24 February 2008 - 10:47 PM

Strange, im able to fraps at 20-30 FPS with everything set to high.

Intel C2D E6400 @ 2.13Ghz
2GB PC5300 DDR2.
Gainward Geforce 8800GT.
7200RPM Sata-2 disk.

Wow-settings set to high with basically everything on @ 1920x1200.

Check if you have an old version of fraps, the newer ones solves alot of problems with new hardware configurations.

You should also untick windowed-mode if you are using it, it gives a nice FPS-boost usually.

#14 bulletsux

bulletsux

    Glass Joe

  • Members
  • 11 posts

Posted 24 February 2008 - 11:10 PM

What OS are you using? I had trouble using FRAPS on Vista with WoW (5 FPS) . However, when I used my XP OS (20-30 FPS), I had better results! Unless things have changed in the last couple of months since I tried, FRAPS doesn't like Vista.
1% partly skimmed strawberry milk

#15 Illundai

Illundai

    Bald Bull

  • Members
  • 1239 posts

Posted 24 February 2008 - 11:10 PM

Gah... I knew it was going to come down to that. I'm running Vista64-bit. >.<

#16 Praetorian

Praetorian

    Mike Tyson

  • ♦ Administrators
  • 27809 posts

Posted 24 February 2008 - 11:13 PM

I have no problem at all using Fraps and WoW with Vista 32bit. I did have to disable SLI, however.

#17 Illundai

Illundai

    Bald Bull

  • Members
  • 1239 posts

Posted 24 February 2008 - 11:25 PM

Slap me silly and call me stupid, but I didn't realise the newest version of FRAPS had 64 bit support. Well, there you go I guess. Frapsing at 50 fps now.

#18 kniff

kniff

    Glass Joe

  • Members
  • 16 posts

Posted 25 February 2008 - 12:53 AM

Slap me silly and call me stupid, but I didn't realise the newest version of FRAPS had 64 bit support. Well, there you go I guess. Frapsing at 50 fps now.


Glad it worked out for you!

#19 Kuosi

Kuosi

    Von Kaiser

  • Members
  • 84 posts

Posted 26 February 2008 - 04:48 AM

There's so many things that can affect FRAPS performance greatly so don't go slapping yourself silly if you miss one :P

#20 Eph

Eph

    Don Flamenco

  • Members
  • 293 posts

Posted 26 February 2008 - 09:24 PM

I hope this isn't too much off the subject, but does anyone have some advice for video compression, specifically in Sony Vegas? I'm a step or two beyond the OP and after finally getting Fraps to work on my machine and editing a short video I've become stumped in trying to give my rendered videos the look and quality of ones I've seen. Anyone have specific codecs, bitrates, or other numbers that work for them that they might be willing to share?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users