Jump to content


Photo

DPSSim Simulation Tool


  • Please log in to reply
86 replies to this topic

#81 deew

deew

    Glass Joe

  • Members
  • 2 posts

Posted 28 September 2009 - 02:21 PM

Edit: ...

#82 Romilly

Romilly

    Glass Joe

  • Members
  • 6 posts

Posted 28 September 2009 - 11:33 PM

Any idea?

/System/Library/Frameworks/JavaVM.framework/Versions/1.4.2//Commands/java -jar ~/Downloads/DPSSim.jar
Exception in thread "main" java.lang.UnsupportedClassVersionError: gemm/sim/DPSSimGUI (Unsupported major.minor version 50.0)
at java.lang.ClassLoader.defineClass0(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:539)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:123)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:251)
at java.net.URLClassLoader.access$100(URLClassLoader.java:55)
at java.net.URLClassLoader$1.run(URLClassLoader.java:194)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:187)
at java.lang.ClassLoader.loadClass(ClassLoader.java:289)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:274)
at java.lang.ClassLoader.loadClass(ClassLoader.java:235)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:302)

#83 Gruntle

Gruntle

    King Hippo

  • Members
  • 509 posts

Posted 29 September 2009 - 07:56 AM

Any idea?

/System/Library/Frameworks/JavaVM.framework/Versions/1.4.2//Commands/java -jar ~/Downloads/DPSSim.jar
Exception in thread "main" java.lang.UnsupportedClassVersionError: gemm/sim/DPSSimGUI (Unsupported major.minor

As far as I can tell you're running Java 1.4.2, 1.6 is needed to run the program.

#84 Romilly

Romilly

    Glass Joe

  • Members
  • 6 posts

Posted 29 September 2009 - 10:39 PM

Hi Tankietka,

May want to update the first post if you can, to say that it requires Java 1.6 -that's what threw me. Eventually these notes will get buried.

Also, just editting to confirm 1.6 works just fine on the Mac. You need to make sure your current version is 1.6 or need to directly reference the java vm.

/System/Library/Frameworks/JavaVM.framework/Versions/1.6/Commands/java -jar ~/Downloads/DPSSim.jar

Awesome, looking forward to finding out why my dps is subpar :)

One thing I noticed was the execute if rage is < 25 -- I didnt understand that - my guess its supposed to execute if target health is < X ?

#85 Gruntle

Gruntle

    King Hippo

  • Members
  • 509 posts

Posted 30 September 2009 - 07:32 AM

The execute if rage<25 is probably just a leftover from old times. When Execute ate up the entire rage bar it was sometimes favorable to do BT instead of it in a fury cycle. This depended on the current rage and the amount of AP you had. Don't use that condition.

Also, make sure that you run the simulation for long enough, otherwise you will not get anything useful out. I would recommend running it for at least 100,000 sec. An easy check to see whether you're running it long enough is too run it 2-3 times with that time (yeah, it takes some time) and make sure that the resulting dps doesn't change by too much. For SEP, you probably need to run it overnight, run at least 10 iterations at 100,000 seconds each.

#86 Tankietka

Tankietka

    Piston Honda

  • Members
  • 118 posts

Posted 13 October 2009 - 06:11 AM

Hello everyone,

Unfortunately due to time and real life constraints I cannot put into DPSSim much time currently. I will try to update it with some easy/fast to implement changes, but for new features it is not enough. If someone would like to help to improve it and try to add something new, here are full sources:

http://alan.umcs.lub...wow/sources.zip

#87 theidealist

theidealist

    Glass Joe

  • Members
  • 1 posts

Posted 21 October 2009 - 04:03 AM

this is wt my console says:


Exception in thread "main" java.lang.UnsupportedClassVersionError: Bad version number in .class file
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:620)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:124)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:260)
at java.net.URLClassLoader.access$100(URLClassLoader.java:56)
at java.net.URLClassLoader$1.run(URLClassLoader.java:195)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:268)
at java.lang.ClassLoader.loadClass(ClassLoader.java:251)
at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:319)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users